CentOS 6 升級php版本至7.0.32

C

最近因為想使用LikeCoin,在原本網站安裝likecoin外掛後,發現無法啟用,會一直發生錯誤。去LikeCoin的紛絲專頁詢問,得到回覆是,網站主機必須要在php5.4 以上的版本。
後來去確認自己使用的虛擬主機,發現是php5.3.9。

寄信給虛擬主機的客服,經過一個星期沒有回應,那時候剛好又想嘗試用google cloud platform(GCP)架站
所以決定乾脆自己用GCP建一個主機來跑wordpress,在自己升級php版本

GCP建立主機+架設wordpress+綁定網域 ,查了很多教學後來終於成功
因為有很多教學都是前面懂,中間有一兩句話不懂,然後就卡在那邊,所以查了好幾篇綜合在一起,如果也想用GCP架站的人,可以來信詢問(zomzad@gmail.com),之後應該會寫一篇當筆記,如果寫了大家可以參考看看

這篇主要是紀錄,主機建立完成後,如何升級php的步驟

如果是用gcp架站,在他們的Compute Engine選單中,針對你建立的執行個體,在右側會有一個寫著[SSH]的三角形圖示
點選後,選擇在瀏覽器視窗中開啟,可以開啟終端機介面。接著透過下面指令,就可完成php的升級

1.安裝PHP的yum來源庫

 

2.安裝php7

 

3.安裝所有php7相關套件

 

4.安裝yum替換套件

 

5.替換目前php套件至php7

 

6.重新啟動apache httpd服务

 

這樣就完成php的升級
可以到主機的cpanel後台確認php的版本
或者你可以在wordpress的頁尾或其他檔案
加入php語法確認畫面回應的版本是不是php7

 

關於作者

留言

By zomzad
聯繫本站: zomzad@gmail.com

TAG